Intermittent Issues with Engage Platform
Incident Report for GeckoEngage
Resolved
This incident has been resolved.
Posted Jan 29, 2025 - 15:06 GMT
Update
Services are returning to normal following our implemented workarounds and recent fixes from AWS. Testing across forms, events, and both US and UK customers has shown positive results. Our team is continuing to monitor for any further issues.

Ongoing incident at AWS can be tracked here: https://health.aws.amazon.com/health/status
Posted Jan 29, 2025 - 09:54 GMT
Update
We are still experiencing errors with Engage forms and are actively working on restoring functionality. Our team is exploring workarounds to mitigate the impact of the ongoing AWS outage. We will provide updates as soon as we have more information.
Posted Jan 29, 2025 - 09:06 GMT
Monitoring
The issue seems to be related to Amazon Web Services, who are our main provider of web services. Our team have changed some configuration to work around the issue, and we believe the issue is now resolved - we will continue to monitor the situation. If you are still experiencing issues, please reach out to a member of the Customer Success team.
Posted Jan 29, 2025 - 08:45 GMT
Investigating
We are experiencing intermittent issues with the engage platform serving a 404 error after logging in. We are currently investigating the issue. Apologies for the inconvenience caused.
Posted Jan 29, 2025 - 08:34 GMT
This incident affected: European Region (Website).