Reduced availability of GeckoForm API

Incident Report for GeckoEngage

Resolved

This incident has been resolved.
Posted Feb 14, 2019 - 16:47 GMT

Monitoring

We have identified an issue with DNS resolution of the GeckoForm API which is causing issues loading public forms and login into GeckoForm.
This issue has now been resolved however it can take a few minutes for this change to fully propagate to all ISPs. Please try refreshing or reopening your browser.
Posted Feb 14, 2019 - 15:38 GMT