US REGION: We have identified an intermittent issue with submitting forms in our US region. Our engineers have already created and deployed a patch to resolve the problem, and we are actively monitoring it.
Incident Report for GeckoEngage
Resolved
This incident has been resolved.
Posted May 04, 2022 - 23:03 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 03, 2022 - 22:20 BST
This incident affected: US East Region (Website).