System outage
Incident Report for GeckoEngage
Resolved
This incident has been resolved.
Posted May 10, 2022 - 08:18 BST
Update
Our EU region is experiencing reduced throughput for some background activities as we rebuild our cache.
Please bear with us as we work to restore full capacity.

Our US region is operating at full capacity.
Posted May 09, 2022 - 18:10 BST
Monitoring
We have implemented a fix and can now see functionality returning to normal.
Posted May 09, 2022 - 16:55 BST
Update
We are continuing to work on a fix for this issue.
Posted May 09, 2022 - 16:53 BST
Identified
We're identified an issue with logging into the Engage admin site, a fix is being implemented we expect this to be resolved shortly
Posted May 09, 2022 - 16:52 BST
This incident affected: US East Region (API, Website) and European Region (API, Website).