Outage with Engagement Widget

Incident Report for GeckoEngage

Resolved

This incident has now been resolved and all Engagement widgets are now working as expected. If you are still experiencing an issue with your Engagement widget, please reach out to a member of the Customer Success team.
Posted Jul 21, 2026 - 12:05 BST

Investigating

We are currently experiencing an outage affecting all Engagement widgets, rendering them unavailable. This is only affecting the Engagement widget - users with Chat widget are still operational. We are currently investigating the issue.
Posted Jul 21, 2026 - 10:28 BST