Elevated API Errors

Incident Report for GeckoEngage

Resolved

This incident has been resolved.
Posted Apr 25, 2018 - 13:41 BST

Monitoring

At 9:24 one of our read-replica databases encountered problems and began failing to respond to a portion of queries, resulting in increased errors and reduced performance.
At 9:33 the specific database was identified and rebooted, however, due to these problems a restart was not possible and database recovery was automatically instigated. Around this time a larger number of errors were seen and clients reported this to our Customer Success team.
At 9:38 the recovery process completed, no more errors have been reported in our monitoring systems and all clients have confirmed they are able to access GeckoSystems without issue.

All system are now running again without issue, but we are continuing to investigate the cause of the problems encountered by this replica database.
Posted Apr 25, 2018 - 10:56 BST

Investigating

We're experiencing an elevated level of API errors in our EU region and are currently looking into the issue.
Posted Apr 25, 2018 - 10:31 BST