Data Processing Delays
Incident Report for GeckoEngage
Resolved
All backlogged data has now been processed, we apologise for any inconvenience this may have caused.
Posted Mar 30, 2017 - 11:43 BST
Monitoring
Our data processing infrastructure is experiencing higher than expected inbound data which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up shortly.
Posted Mar 30, 2017 - 11:24 BST